Back
Maintenance

Kamino Platform Maintenance

Completed 7 Jan at 01:00pm CET.

platform.kaminoretail.com api.kaminoretail.com
Completed

Maintenance completed

Posted 7 Jan at 01:00pm CET.
Started

Dear Kamino Retail Platform users,

Please be advised that our platform will undergo scheduled maintenance on 07/01/2026 from 12:00 to 1:00PM (CET). During this period, access to the platform may be temporarily unavailable.

We apologize for any inconvenience this may cause and appreciate your patience and understanding as we work to enhance the performance and reliability of our services.

If you have any urgent inquiries, please don't hesitate to contact our support team at support[at]Kamino Retail | Retail Media Monetization Platform .

Thank you for your cooperation.

Sincerely,
Kamino Retail

Posted 7 Jan at 12:00pm CET.