Back
Downtime

Delivery is unavailable

Started , resolved .

delivery.kaminoretail.io
Resolved

Issue is now resolved, we continue to monitor the situation in order to confirm that all services are fully operational.

Posted .
Updated

We've currently experiencing networking issues, some service may be degraded

Posted .
Created

We're currently experiencing issues with our Ads Delivery server. We're investigating the issue

Posted .